[coreboot] Acer c720p: seabios is gone after enabling write protection

Yannick sevmek at free.fr
Wed Feb 5 19:08:21 CET 2014

Le mercredi 05 février 2014 à 09:36 -0600, Aaron Durbin a écrit :
> On Wed, Feb 5, 2014 at 3:04 AM, Yannick <sevmek at free.fr> wrote:
> > Hi,
> >
> > I'm the one who tried to help Carmelo. Unfortunately, after I opened
> > this machine (Acer c720p, french keyboard) and removed the screw to
> > enable writing on coreboot, it now refuses to access to seabios if I
> > press CTRL + L has I did before so many times. It just emits a sound "bip" when doing so.
> > I've put the screw back in, it's still the same.
> >
> > Thus the fedora 20 I installed is now out of reach.
> >
> > If I wait ~30 seconds, I've a second white screen proposing to reinstall
> > ChromeOS using USB or SD. I hope I someone here can save me the trouble
> > of reinstalling ChromeOS, then wipe it again, then reinstall Fedora 20
> > and reconfigure it...
> >
> > Process I'm trying to get it working back:
> > 1- using a distro (ubuntu 12.04 in my case) prepare an USB stick with chromeos recovery using this script :
> > https://support.google.com/chromebook/answer/1080595
> > -> https://dl.google.com/dl/edgedl/chromeos/recovery/linux_recovery.sh
> > 2- turn on os verification in coreboot
> > 3- reboot and at the warning screen telling you chromeos is missing insert the USB stick.
> > 4- I've a "unexpected error" during recovery process. :/
> >
> > I'm stuck...
> >
> >
> You need access to the chromeos-firmwareupdate script and flashrom as
> documented here:
> http://www.coreboot.org/pipermail/coreboot/2014-February/077158.html
> You could ask your friend to copy chromeos-firmwareupdate as well as
> flashrom to your machine. The script is self hosting and flashrom is
> statically linked:
> # ldd /usr/sbin/flashrom
>         not a dynamic executable

The current issue is I only have access to the white screen from
coreboot, there is no seabios available.

Thus I'm trying to reinstall Chrome OS.

I find out there is a log on the USB flash drive I'm using for the
Chrome OS recovery which might explain the failure and maybe solve my
issue at the same time.

In recovery.log, before running some diagnostics at the end of the file,
there is this error:

"Touch(/mnt/stateful_partition/.install_completed) FAILED
Starting firmware updater
Command: /tmp/install-mount-point/usr/sbin/chromeos-firmwareupdate
Starting Peppy firmware updater v4 (recovery)...
 - Updater package: [Google_Peppy.4389.81.0 / peppy_v1.5.114-5d52788]
 - Current system:  [RO:Google_Peppy.4389.78.0 ,
ACT:Google_Peppy.4389.78.0 / peppy_v1.5.113-2d79820]
 - Write protection: Hardware: ON, Software: Main=off EC=ON
Upgrading from early-MP firmware.

        RW firmware update is not compatible with current RO firmware.
        Starting full update...
ERROR: You need to first disable hardware write protection.
ERROR: Execution failed: ./updater4.sh (error code = 4)
Finished after 2 seconds.
Command: /tmp/install-mount-point/usr/sbin/chromeos-firmwareupdate
--mode=recovery - Exit Code 4
RO Firmware needs update, but is really marked RO. (error code: 4)
Rolling back update due to failure installing required firmware.
Successfully updated GPT with all settings to rollback.
PostInstall Failed"

Do you guys think the recovery fails because I do have the screw
protecting coreboot in?
Should I remove this screw and try again?

> -Aaron

More information about the coreboot mailing list