[coreboot] Acer c720p: seabios is gone after enabling write protection

Aaron Durbin adurbin at chromium.org
Wed Feb 5 16:36:02 CET 2014

On Wed, Feb 5, 2014 at 3:04 AM, Yannick <sevmek at free.fr> wrote:
> Hi,
> I'm the one who tried to help Carmelo. Unfortunately, after I opened
> this machine (Acer c720p, french keyboard) and removed the screw to
> enable writing on coreboot, it now refuses to access to seabios if I
> press CTRL + L has I did before so many times. It just emits a sound "bip" when doing so.
> I've put the screw back in, it's still the same.
> Thus the fedora 20 I installed is now out of reach.
> If I wait ~30 seconds, I've a second white screen proposing to reinstall
> ChromeOS using USB or SD. I hope I someone here can save me the trouble
> of reinstalling ChromeOS, then wipe it again, then reinstall Fedora 20
> and reconfigure it...
> Process I'm trying to get it working back:
> 1- using a distro (ubuntu 12.04 in my case) prepare an USB stick with chromeos recovery using this script :
> https://support.google.com/chromebook/answer/1080595
> -> https://dl.google.com/dl/edgedl/chromeos/recovery/linux_recovery.sh
> 2- turn on os verification in coreboot
> 3- reboot and at the warning screen telling you chromeos is missing insert the USB stick.
> 4- I've a "unexpected error" during recovery process. :/
> I'm stuck...

You need access to the chromeos-firmwareupdate script and flashrom as
documented here:


You could ask your friend to copy chromeos-firmwareupdate as well as
flashrom to your machine. The script is self hosting and flashrom is
statically linked:

# ldd /usr/sbin/flashrom
        not a dynamic executable


More information about the coreboot mailing list