[coreboot] qemu-armv7: code execution out of RAM or ROM using latest QEMU

ron minnich rminnich at gmail.com
Mon Aug 11 16:36:42 CEST 2014

So, if you comment that one line out, do things work for you? Just
double checking.


On Mon, Aug 11, 2014 at 2:09 AM, Piotr Król <pietrushnic at gmail.com> wrote:
> On Mon, Aug 11, 2014 at 12:15:32AM +0200, Peter Stuge wrote:
>> > There is no coreboot gdb support
>> There is some gdb support in coreboot, but maybe not for ARM?
> What I tried to say is that it happens to early to connect to coreboot
> using gdb support, but maybe I'm wrong.
>> > so I used qemu '-s -S'. Whole qemu command:
>> >
>> > qemu-system-arm -M vexpress-a9 -m 1024M -nographic -kernel build/coreboot.rom
>> Is -kernel really correct for coreboot.rom ?
> This is option from commit message when qemu-armv7 was introduced
> (7635a60). I also tried '-bios' but it gives same result but with
> different address (not 0x6001024f but 0x0000024f).
> What I see now is that I made mistake during bisect and it was not the
> correct commit that I point to. The correct change causing problem is
> exactly one before:
> http://git.qemu.org/?p=qemu.git;a=commit;h=6ec1588e09770ac7e9c60194faff6101111fc7f0
> Sorry for confusion - first time bisect user. This commit is directly
> related to vexpress-a9 board.
> Piotr
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot

More information about the coreboot mailing list