[coreboot] qemu-armv7: code execution out of RAM or ROM using latest QEMU

Piotr Król pietrushnic at gmail.com
Mon Aug 11 11:09:38 CEST 2014

On Mon, Aug 11, 2014 at 12:15:32AM +0200, Peter Stuge wrote:
> > There is no coreboot gdb support
> There is some gdb support in coreboot, but maybe not for ARM?

What I tried to say is that it happens to early to connect to coreboot
using gdb support, but maybe I'm wrong.

> > so I used qemu '-s -S'. Whole qemu command:
> >
> > qemu-system-arm -M vexpress-a9 -m 1024M -nographic -kernel build/coreboot.rom
> Is -kernel really correct for coreboot.rom ?

This is option from commit message when qemu-armv7 was introduced
(7635a60). I also tried '-bios' but it gives same result but with
different address (not 0x6001024f but 0x0000024f).

What I see now is that I made mistake during bisect and it was not the
correct commit that I point to. The correct change causing problem is
exactly one before:


Sorry for confusion - first time bisect user. This commit is directly
related to vexpress-a9 board.


More information about the coreboot mailing list