[coreboot] Issues getting ASUS F2A85-M to boot

Ward Vandewege ward at gnu.org
Tue Oct 29 17:56:06 CET 2013

On Tue, Oct 29, 2013 at 02:29:14PM -0000, Haywood-Evans Matthew wrote:
> I am presently looking at trying to get Coreboot up and running on an
> ASUS F2A85-M system. I am however running into some issues.  
> Using a bus pirate and flashrom I first backed up the original bios,
> then erased the chip and restored the bios to ensure I had the basic
> read/write capability working and this all worked correctly.
> Then I proceeded to build a standard coreboot image using seabios as a
> payload (using an external VGA card), leaving all the settings as
> default apart from selecting the motherboard, upon writing this to the
> flash and rebooting the machine I had no output from the VGA adapter and
> nothing from the serial port.

How did you burn the image? With the bus pirate, or from the board itself? 

If the latter, that would explain your problem; I've seen flashrom seemingly
do the right thing when reflashing coreboot over the proprietary bios, but
the board not boot. I didn't have time to investigate that at the time,

Re-flashing with the bus pirate solved this for me. Note that you really
still need to power off the board entirely (and let it sit a few seconds to
allow the caps to drain) when switching between proprietary bios and

For me this port works out of the box with the default settings. If you like
I can send you a link to a known-good image that we use here, so that you can
verify your hardware is ok.


Ward Vandewege             | CTO, Free Software Foundation
GPG Key: 25F774AB          | http://status.fsf.org/ward
http://fsf.org/blogs/RSS   | http://identi.ca/cure

Do you use free software? Donate to join the FSF and support freedom at

More information about the coreboot mailing list