[coreboot] Issues getting ASUS F2A85-M to boot

Idwer Vollering vidwer at gmail.com
Tue Oct 29 16:41:03 CET 2013

2013/10/29 Haywood-Evans Matthew <MAHEVANS at qinetiq.com>:
> Hi,
> I am presently looking at trying to get Coreboot up and running on an
> ASUS F2A85-M system. I am however running into some issues.
> Using a bus pirate and flashrom I first backed up the original bios,
> then erased the chip and restored the bios to ensure I had the basic
> read/write capability working and this all worked correctly.

My board came with AMI (U)EFI v5018.

I was able to erase, and write to, every part of the flash chip with
that particular version while leaving the chip in its socket.
v6404 wasn't that permissive anymore.

> Then I proceeded to build a standard coreboot image using seabios as a
> payload (using an external VGA card), leaving all the settings as
> default apart from selecting the motherboard, upon writing this to the
> flash and rebooting the machine I had no output from the VGA adapter and
> nothing from the serial port.

SeaBIOS should run the optionrom that is present on/for the offboard GPU.

> Next I removed the external VGA and followed the instructions at
> http://www.coreboot.org/ASUS_F2A85-M  taking a local copy of the VGA
> bios and embedding that into the coreboot image, rebuilt and re-flashed
> to get the same result as previous.

The APU's PCI ID ofcourse varies, these lines are there (in dmesg and
lspci -nn) when booting linux:

[    0.047202] smpboot: CPU0: AMD A8-5500 APU with Radeon(tm) HD
Graphics (fam: 15, model: 10, stepping: 01)

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.
[AMD/ATI] Trinity [Radeon HD 7560D] [1002:9904]

> After some investigation I created a serial ice image and loaded that,
> this worked giving me a serial ice prompt on the COM port.  Using this,
> and the QEMU provided, I proceeded to try and run the bios files created
> in the last two stages, in the serial ice I see a lot of reads (takes
> about 20 mins) before it exits with Bad memory pointer and core dumps.
> I have been building the coreboot images on a different machine to the
> target (Core i7) but have rebuilt them with the crossgcc in case issues
> with the development PC where causing the issue, however I got the same
> results.
> I am now at a loss of where to go next to get this working and would
> appreciate any insight.
> The target system I am working on is
> F2A85-M
> 4GB Corsair Ram

What's the full name of that memory module? More important: what's its
working voltage?
One can confirm from coreboot's menu: mainboard -> DDR3 memory voltage

> AMD A10 6800K FM2 CPU

Assuming that the PCI ID of the abovementioned APU is 1002:990c, *and
the sha1sum of the with dd from memory extracted VGA optionrom (while
the AMI software is booted) is
e8fd60fd8746ab7f1a997897807d3fdbd119bf7e*, I can provide a working
image: http://ra.openbios.org/~idwer/f2a85-m/coreboot_1002_990c.rom

See http://pci-ids.ucw.cz/read/PC/1002/990c

> Thanks
> Matt



More information about the coreboot mailing list