[coreboot] fam15tn hudson PCIe GPP ports off after resume

Rudolf Marek r.marek at assembler.cz
Wed Nov 13 09:35:24 CET 2013

Hi all,

I fixed the memory voltage cut-off problem on Asus F2A85-M [1], but I have now 
other problem. The GPP ports of hudson SB are gone after resume from S3. The 
devices 15.0 and 15.1 are disabled (decodes as ffff), therefore anything behind 
them too. I tried to debug that for some hours but so far no luck. It looks like 
there is something wrong with PortPresent in GPP structure, but I'm not sure. I 
also noticed that CMOS_RAM is used for this part of AGESA.

Zheng, please do you know what this could be? I tried with your recent (and now 
merged) change for s3 handling but it did not help.

Idwer and Zheng also reported that USB does not work after suspend (this seems 
to be generic fam15tn problem).

So far the board resumes even back to X, (although I dont use USB) but ethernet 
controller is dead (it is behind the SB GPP).

[1] http://review.coreboot.org/#/c/4041/


More information about the coreboot mailing list