[coreboot] coreboot-libpayload 'size_t' conflicting type error

Paul Menzel paulepanter at users.sourceforge.net
Mon Mar 25 22:20:24 CET 2013

Dear Pradish,

welcome to coreboot and sorry, that you hit a problem right away.

As a side note, please configure Google Mail to not send any HTML
message and just plain text. For more information please read the
netiquette for example documented in the openSUSE Wiki [1].

Am Donnerstag, den 21.03.2013, 15:31 +0530 schrieb Pradish Moorkkth Puttan Vettil:


> Next I tried to build libpayload and when I do “make install “ it gives the
> following error****
> ** **
> /coreboot/payloads/libpayload$ make install****
> CC   libpci/libpci.libpci.o****
> In File included from include/libpayload.h:54:0,****
>                  from libpci/libpci.c:30:****
> include/x86/arch/types.h:56:22: error: conflicting types for 'size_t'****
> In file included from include/libpayload.h:49:0,****
>                  from libpci/libpci.c:30:****
> /home/pradish/coreboot/util/crossgcc/xgcc/lib/gcc/i386-elf/4.7.2/include/stdded.h:213:23:
> note: previous declaration of 'size_t' was here****
> make: ***[build/libpci/libpci.libpci.o] Error 1****

You also reported this issue in the coreboot Trac instance [2]. Thank
you. But I think we can leave the discussion on this list.

I am getting the same error and I think you should revert the patch
introduced with [3].

        commit 903f8e03307de8a689244eec5bf9aface73850b1
        Author: Gabe Black <gabeblack at google.com>
        Date:   Tue Feb 26 23:18:24 2013 -0800

            libpayload: Add size_t and ssize_t types for ARM and x86

For the beginning you can register also at the Gerrit instance (with an
OpenID account) and also report there your findings.

So to fix the error, as a workaround you can do

    $ git revert 903f8e03

and it should work.



[1] http://en.opensuse.org/openSUSE:Mailing_list_netiquette
[2] https://tracker.coreboot.org/trac/coreboot/ticket/191
[3] http://review.coreboot.org/#/c/2669/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130325/f5d995ba/attachment.sig>

More information about the coreboot mailing list