[coreboot] Problem with coreboot+SeaBIOS on Samsung Chromebox (stumpy)

Robert Ou rqou at berkeley.edu
Sun Jun 16 03:17:31 CEST 2013


I tried to build and flash coreboot and SeaBIOS onto a Samsung Chromebox. I
built coreboot from master of the coreboot tree (no chromiumos patches). My
problem is that the Chromebox now only boots from a complete cold boot. In
other words, I need to unplug both the AC power and the RTC battery, then
plug in the AC power, and then push the power button. If I run "shut down"
from Ubuntu and try to press the power button, the board does not boot. If
I hold the power button until the box shuts off and push the power button
again, it also does not boot. If I suspend from Ubuntu, the box suspends
and the blue LED starts blinking. However, if I push the power, it doesn't
resume. One thing I observed is that all the boots that don't work involve
the power LED either never turning on or turning on instantly. The complete
cold boot that does work has the power LED blinking very briefly, turning
off for several seconds, and then turning back on. Does anybody know what
is going on here? Attached is a cbmem console log of a successful boot, but
I don't know how to get console logs from failed boots.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130615/f54d3d0c/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cbmem-ok.log
Type: application/octet-stream
Size: 48032 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130615/f54d3d0c/attachment-0001.obj>

More information about the coreboot mailing list