[coreboot] New patch to review for coreboot: 523c9f8 Siemens SITEMP G1P1: mainboard.c: Rename `init` to `mainboard_init`

Paul Menzel (paulepanter@users.sourceforge.net) gerrit at coreboot.org
Sat Feb 23 21:50:38 CET 2013


Paul Menzel (paulepanter at users.sourceforge.net) just uploaded a new patch set to gerrit, which you can find at http://review.coreboot.org/2491

-gerrit

commit 523c9f8d0df5d528071932c84749782474acfd87
Author: Paul Menzel <paulepanter at users.sourceforge.net>
Date:   Sat Feb 23 19:33:19 2013 +0100

    Siemens SITEMP G1P1: mainboard.c: Rename `init` to `mainboard_init`
    
    This is the common way to name that function, so unify that.
    
    Change-Id: I8a01051bd304039662894b89eed53ce14dde98b6
    Signed-off-by: Paul Menzel <paulepanter at users.sourceforge.net>
---
 src/mainboard/siemens/sitemp_g1p1/mainboard.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/mainboard/siemens/sitemp_g1p1/mainboard.c b/src/mainboard/siemens/sitemp_g1p1/mainboard.c
index a73fbd6..c2f9e70 100644
--- a/src/mainboard/siemens/sitemp_g1p1/mainboard.c
+++ b/src/mainboard/siemens/sitemp_g1p1/mainboard.c
@@ -806,7 +806,7 @@ static void smm_lock( void )
  * @param the root device
  */
 
-static void init(device_t dev)
+static void mainboard_init(device_t dev)
 {
 #if CONFIG_PCI_OPTION_ROM_RUN_REALMODE
 	INT15_function_extensions int15_func;
@@ -845,7 +845,7 @@ static void enable_dev(device_t dev)
 	detect_hw_variant(dev);
 	update_subsystemid(dev);
 
-	dev->ops->init = init;  // rest of mainboard init later
+	dev->ops->init = mainboard_init;  // rest of mainboard init later
 }
 
 struct chip_operations mainboard_ops = {



More information about the coreboot mailing list