[coreboot] [RFC] mainboard.c: Unify name of device/board enable function

Peter Stuge peter at stuge.se
Fri Feb 22 02:17:12 CET 2013

Paul Menzel wrote:
>         struct chip_operations mainboard_ops = {
>         	.enable_dev = inagua_enable,
>         };
> Naming this function is not uniform between the boards in the tree.

Depending on how mainboard_ops is used in all the boards maybe we
want to simply remove it completely.

> If there are no objections to unification, what should the name for the
> function be?

Function names should try to be descriptive. "enable_dev" is not very
descriptive. I like "mainboard_enable" because it makes output such

printk("%s: foo", __func__);


> Please comment on this, so a patch can be submitted.

I'd +2 a commit which renames all to mainboard_enable. It would be
very nice to also add a test for this to the Jenkins build.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130222/7acfb63b/attachment.sig>

More information about the coreboot mailing list