[coreboot] Problem in building coreboot + FILO for ASI_MB-5BLMP

Andrew Wu andrewwu.tw at gmail.com
Fri Aug 30 15:07:31 CEST 2013


Maybe you didnt' install toolchain correctly. But coreboot can build
its own toolchain, you can try:

  cd util/crossgcc/

Building toolchain takes long time. After it is done, you can try to
compile libpayload again.

  cd ../../payloads/libpayload/
  make clean

2013/8/24 michele.montani at libero.it <michele.montani at libero.it>:
> Hi,
> I'm trying to make live again an old thin client based on ASI_MB-5BLMP
> motherboard. The original BIOS is blocked and I can't use it as is, so I
> thought to use coreboot and FILO, following the instructions found in "How to
> build".
> I retrived an old pc, installed Lubuntu and all packets listed in coreboot
> instructions: gcc / g++, make, ncurses-dev (when installed, a note from apt-get
> said that was selected libncurses5-dev), doxygen, iasl, gdb, flex and bison,
> used git for coreboot and FILO and, following instructions, tried to build
> libpayload. When I run "make menuconfig", I can set options and write them to .
> config, obtaining the following output:
> (‘comando non trovato’ means ‘command not found’)
> michele at pcscratch01:~/coreboot/payloads/libpayload$ sudo make menuconfig
> [sudo] password for michele:
> /bin/sh: -print-libgcc-file-name: comando non trovato
> /bin/sh: -print-libgcc-file-name: comando non trovato
> #
> # configuration written to .config
> #
> *** End of libpayload configuration.
> *** Execute 'make' to build or try 'make help'.
> When I try to run "make install" (or "make"), the output is:
> michele at pcscratch01:~/coreboot/payloads/libpayload$ sudo make install
> /bin/sh: -print-libgcc-file-name: comando non trovato
> /bin/sh: -print-libgcc-file-name: comando non trovato
> build/libpayload-config.h build/config.h differenza: byte 92, riga 4
>     CC         libpci/libpci.libpci.o
> make: MMD: comando non trovato
>     AR         build/libpci.a
> make: rc: comando non trovato
> make: *** [build/libpci.a] Errore 127
> And here I stopped.
> I googled to find some indication, and all I could find is to delete sh link
> and recreate it pointing to /bin/bash.
> I'm not expert in Linux world, nor in programming, and I discovered coreboot
> just because I'm looking for a new BIOS for my motherboard, so I really need
> for a little help.
> Thanks in advice for every suggestion you could give to me.
> Regards
> Michele Montani
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot

More information about the coreboot mailing list