[coreboot] Win7 boot

A Shirwaikar, Atita Atita.Shirwaikar at lsi.com
Fri Oct 26 12:13:14 CEST 2012

Hi Peter

Thanks for your response. We went ahead and tried to boot Windows XP.It throws this error

"Enable the local advanced programmable interrupt controller (APIC).
The x64-based operating system you are loading does not have APIC enabled. Check the system's firmware settings and
make sure that the firmware has enabled the APIC on this system. If the firmware does not have an APIC setting, please 
contact the system manufacturer for a firmware update to enable the local APIC."

I tried enabling CONFIG_IOAPIC in .config and doing a make. That did nothing. So I enabled it explicitly in config.h
That stalled boot with this error "get_pbus dev is null"

How do we get XP to boot using coreboot.Appreciate your help..

-----Original Message-----
From: Peter Stuge [mailto:peter at stuge.se] 
Sent: Friday, October 26, 2012 2:37 AM
To: A Shirwaikar, Atita
Cc: coreboot at coreboot.org; Nandi, Manasij; Kondejkar, Ashutosh
Subject: Re: [coreboot] Win7 boot


A Shirwaikar, Atita wrote:
> In Qemu environment and using coreboot, we are trying to install 
> Windows 7 on our virtual disk. Installation fails throwing this error.
> "Windows failed to load because the firmware (BIOS) is not ACPI 
> compatible"
> What do we do to get past this error. Kindly help

You start debugging the ACPI tables, and specifically in the context of what Windows thinks of them.

You'll at a minimum need a checked build of Windows 7, some way to communicate with WinDbg, and lots of time.

Another, complementary, approach is to compare with another data set.
So you would start Windows 7 using qemu without coreboot, see if that works, and if so then study the ACPI differences between the two systems.

It's pretty retarded that the Qemu folk refuse to contribute to coreboot and insist on duplicating lots of code within SeaBIOS, but there's not too much to do about that..


More information about the coreboot mailing list