[coreboot] i915tool

Denis 'GNUtoo' Carikli gnutoo at no-log.org
Thu Oct 4 15:11:16 CEST 2012


I had some difficulties getting started with the i915tool:
first I did that:
export LINUX=/home/gnutoo/x86/linux-libre/linux-3.0.0
I installed that PPA: https://launchpad.net/~npalix/+archive/coccinelle 
and coccinelle.
Then I created the following directories(and deleted the files with the
same name if any): inputs/ per-file-changes/ final/ tmp/
then I made plusplusplus executable
and then I ran transform like that:
sh transform

Then I ran make which ended with:
final/intel_bios.c:123:5: error: ‘uint8_t’ undeclared (first use in
this function)
I patched intel_bios.c by adding #include <stdint.h> on top of the
Then I ran make again and I've that:
final/intel_bios.c:594:24: error: ‘intel_no_opregion_vbt’ undeclared
(first use in this function)

I'll continue to try to make it "work" (not sure if it does work at all
since you have to "make broken" according to the git commit).

However I see that you have a much updated version according to
a comment in http://review.coreboot.org/#/c/1003/ 


More information about the coreboot mailing list