[coreboot] Patch merged into coreboot/master: 6e711c6 libpayload: Add init() function to hci_t and rework uhci_reset()

gerrit at coreboot.org gerrit at coreboot.org
Wed Nov 14 17:45:16 CET 2012

the following patch was just integrated into master:
commit 6e711c6a97a9d4122615018121d0d2a37b642ed1
Author: Nico Huber <nico.huber at secunet.com>
Date:   Mon Nov 12 16:20:32 2012 +0100

    libpayload: Add init() function to hci_t and rework uhci_reset()
    uhci_reset() differs in semantics compared to the other HCI's reset()
    implementations. uhci_reset() does some initialization work after a
    controller reset. So move the initialization part to a new function,
    uhci_reinit(), which get's exported through a new entry in hci_t:
    Warning: This breaks code that relies on the current, special,
    counterintuitive behaviour of uhci_reset(). If one wants a working host
    controller after calling hci_t.reset(), he should call hci_t.init()
    Change-Id: Ia7ce80865d12d11157645ce251f77f349f8e3c34
    Signed-off-by: Nico Huber <nico.huber at secunet.com>
    Reviewed-on: http://review.coreboot.org/1851
    Tested-by: build bot (Jenkins)
    Reviewed-by: Ronald G. Minnich <rminnich at gmail.com>

Build-Tested: build bot (Jenkins) at Wed Nov 14 11:46:40 2012, giving +1
Reviewed-By: Ronald G. Minnich <rminnich at gmail.com> at Wed Nov 14 17:45:15 2012, giving +2
See http://review.coreboot.org/1851 for details.


More information about the coreboot mailing list