[coreboot] GA-6BXE doesn't boot with Intel PRO/1000 GT

Idwer Vollering vidwer at gmail.com
Tue Jun 26 00:14:59 CEST 2012

2012/6/25 Tomi Leppänen <tomppeli12 at gmail.com>:
> Hi,
> I have a Gigabyte GA-6BXE (Rev 2.1) motherboard with coreboot (built last
> week, I think). My processor is Intel Pentium III 550 and I have 786 MiB of
> RAM (actually 1 GiB but the motherboard can't see a part of it). It works
> just fine when I connect graphics card (ATI Rage II3 or Nvidia GeForce 2 MX)
> and some other network card I have (I've got 3Com and some other 100 Mb/s
> NIC). I can even connect both of them and it boots just fine. When I connect
> Intel PRO/1000 GT Desktop Adapter it doesn't boot. Post card gives me code
> 0x9B. Nothing appears to my screen nor it reads CD (System Rescue Disk, that
> is just some random Linux).
> I get the same results if I use ATI Radeon 9200SE as the graphics card (last
> post code is also 0x9B and display is black). Original bios didn't like that
> graphics card but it at least got into console, just had some "overlapping
> memory BAR stuff" I don't know much about and thus I couldn't get X working.
> I haven't tried that Intel NIC with the motherboard's original bios
> (requires flashing it back). I'd like to get that Intel's card working
> because I was about to try making a router out of that old hardware.
> In addition I noticed that my CD drive didn't work correctly if I connected
> it to first IDE connector on motherboard. It had some trouble loading Linux
> and dmesg output following:
> ata1.00: qc_timeout (cmd 0xa0)
> ata1.00: TEST_UNIT_READY failed (err_mask=0x4)
> ata1.00: configured for UDMA/33
> which was repeated twice and later it told me that ata1.00: disabled, it was
> soft resetting link (still ata1.00) and last message about that is "EH
> complete". After that I couldn't use the CD drive. I don't know if there is
> something wrong with my hardware, but the other IDE bus works just fine,
> which I okay, as I don't need more than two devices. I've had problems with
> that motherboard's IDE bus before still using original bios.

I'll wipe the dust off my Asus P2B somewhere (later) this week, and
find out if it works with a 1000GT and a CD/DVD drive.

> If you are going to make some patches or anything, I'd just like you to know
> that I don't have any other 'special' equipment than the (cheap) post card,
> but I have another GA-6BXE (though Rev 1.9) motherboard that beeps
> continuosly when I boot it (still has the original bios). I might be able to
> switch the chips, although the chip with coreboot has one leg broken and I
> use a resistor's leg instead, so it's kind of annoing to fiddle with.
> I also tried the motherboard with IWill Sloket and VIA C3 (1 GHz, Nehemiah
> core), which works nicely with original bios (with 133 MHz×7,5=~1  GHz
> clock), but it didn't work and the last post code is 0x01. The motherboard
> has DIP switches for selecting FSB speed and I tried with 100 and 133 MHz
> settings, neither worked. But that's not the main issue right now, although
> it would be nice to have that setup working too. I could also try one Socket
> 370 Celeron if you want. :)
> Thanks.
> Ps. I hope I didn't make too many typos as it's my second (or third,
> whatever) language (Finns are odd people, you know ;)) and I wrote this at
> midnight. Feel free to ask if you don't understand something. I also know
> that my parts are from different ages and that might be the source of some
> compatibility issues.
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot

More information about the coreboot mailing list