[coreboot] Trying to port abit A-S78H

Prakash Punnoor prakash at punnoor.de
Fri Feb 3 10:17:34 CET 2012

On Sunday 29 January 2012 19:38:47 Peter Stuge wrote:
> Prakash Punnoor wrote:
> > >> - seabios payload: no gfx output, but postcode is F8
> > > 
> > > Focus on this. What is the serial output from coreboot and SeaBIOS?
> > 
> > That's the thing: I don't have a serial port on this mainboard, that's
> > why I had to do painful post code debugging...
> Maybe you can use some of the other methods for debug output. USB
> Debug device or RTL8029?

Thx for the hints. I knew about the USB debug device, but it seems too costly 
and also there is no guarantee it will work. But I have an ancient RTL8029AS 
which I tried. I didn't get any output, though. I configured it properly in 
menuconfig. (I didn't change the default ioport. Linux chooses 0xbf00, but 
0xe00 seems to be free, as well...)  Do I have to call some function in the 
code to enable console output via ethernet? I checked the connection in Linux 
and it worked. (I use a cross-over cable, btw.)

> For serial output from SeaBIOS or later coreboot stages a PCI based
> serial port would also work.

Ok, this would be my second option if above doesn't work.



More information about the coreboot mailing list