[coreboot] Original Supermicro H8QGI-F doesn't work with coreboot

Константин Аладышев aladyshev at nicevt.ru
Fri Aug 24 16:04:11 CEST 2012

We bought original Supermicro motherboard H8QGI-F. Installed on it 4 AMD Opteron processors family15h (model OS6234WKTCGGU - 12 cores). And then properly installed 2 dimms per socket (one per node).
We configured coreboot for this board. But it doesn't work. Memtest passes ok, but system failes in AmdCpuPost (log in attachment).

It seems like system reboots in function "Relinquish control of APs". Is it unplanned reset? After it system find only one node and then failed and stuck.
In this "Relinquish control of APs" we do halt function on every AP in "for" cycle. I input debug message in this cycle and figured out, that reset happens after second halt function. I tried to reverse cycle, but again system reset happend on second halt function. Maybe this little info can help to determine the problem. 
If i comment this function, there will be no reboot and code passes far far away, but according to debug log in this case system work on only one core.

I tried to use current coreboot version and version when Kerry Sheh initially commited code for this board like working and tested (http://review.coreboot.org/#/c/567/). They both have same behaviour for me.

I need some help to figured out the problem

Best regards,
Aladyshev Konstantin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20120824/4eb0fa5f/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20120824/4eb0fa5f/attachment.ksh>

More information about the coreboot mailing list