[coreboot] ASUS M2V problems

G tjmadwja at gmail.com
Mon Apr 23 14:46:07 CEST 2012

On Mon, Apr 23, 2012 at 12:33 PM, ali hagigat <hagigatali at gmail.com> wrote:
> You'd better buy a debug card and plug into the PCI slot and see what
> numbers it will display. It has two seven segment components.
> Besides you can disable coreboot post codes and insert your own post
> codes to see how far the program runs.
> I did the same for my motherboard...

Thanks, but as I wrote on April 13th, I have managed to get some
output over serial, but still nothing on VGA or any response to
keyboard events. Details, and serial log and config file, can be
found in my April 13th message.

> On Wed, Apr 11, 2012 at 1:18 PM, G <tjmadwja at gmail.com> wrote:
>> On Tue, Apr 10, 2012 at 5:26 PM, Marc Jones <marcj303 at gmail.com> wrote:
>>> On Tue, Apr 10, 2012 at 7:37 AM, G <tjmadwja at gmail.com> wrote:
>>>> Hi,
>>>> I'm trying to get coreboot onto my old ASUS M2V (rev. 1.01g)
>>>> motherboard, but so far I've had no luck. I'm currently trying to
>>>> get the coreinfo payload running, as that seems like the simplest
>>>> test case (I've also tried seabios, and failed).
>>>> After flashing, when I boot, nothing happens. No beeps, the
>>>> monitor remains in power-save mode, the keyboard doesn't respond
>>>> to any keypresses (not even holding down several keys for a long
>>>> time generates any beeps), no blinking status LEDs, nothing on
>>>> the serial port. Nothing.
>>>> I've tried with two different revisions, one from 2010-11-24 (the
>>>> one that adds S3 support for ASUS M2V), and one from 2012-02-21
>>>> (all later revisions fail to compile with lots of different CBMEM
>>>> problems).
>>>> In the 2010-11-24 revision, I've had to add
>>>>       reg++; reg--;
>>>> in src/northbridge/amd/amdk8/raminit_f_dqs.c:setup_mtrr_dqs() and
>>>>       regm3++; regm3--;
>>>> in src/southbridge/via/vt8237r/vt8237_ctrl.c:vt8237_cfg() to get
>>>> rid of warnings about unused variables.
>>>> Flashing is done by simply running:
>>>>       ./flashrom -V -w coreboot.rom -c W39V040C
>>>> Does anyone here have any idea what might be wrong? Anyone got a
>>>> working .config, tips to use a certain known working revision, a
>>>> know working version of flashrom (although flashing two different
>>>> versions of ASUS's BIOS using flashrom works well, so I'm
>>>> guessing neither flashrom nor my usage of it is to blame), a
>>>> working coreboot.rom they can share, or anything else that might
>>>> help me move forward?
>>>> Using Debian unstable to build, if that's any help.
>>>> --
>>>> coreboot mailing list: coreboot at coreboot.org
>>>> http://www.coreboot.org/mailman/listinfo/coreboot
>>> Hi,
>>> You will need to capture some output from coreboot to find where your
>>> system is having problems.
>>> http://www.coreboot.org/FAQ#How_do_I_use_a_null-modem_cable_to_get_coreboot_debugging_output_over_a_serial_port.3F
>> Thanks for the reply, but unfortunately, as I wrote in my
>> original mail, I get nothing on the serial port.
>> When I boot the standard ASUS M2V BIOS, with a null-modem cable
>> plugged in, then exactly as I power on the M2V system, minicom on
>> the other end briefly (less than a second) switches from Offline
>> to Online, and then back to Offline, and then the system
>> continues to boot.
>> Booting coreboot, minicom switches from Offline to Online exactly
>> when I power on the M2V system, and then the minicom status on
>> the other machine remains Online, but nothing ever arrives in the
>> minicom terminal window, and nothing else happens (no beeps, not
>> LEDs, nothing on the screen, just plain nothing).
>> I have tested that the minicom connection over null-modem cable
>> between my M2V computer and the other machine works after booting
>> the standard ASUS M2V BIOS, although I then have HW flow control
>> enabled, which is then disabled before trying to boot the
>> coreboot BIOS. And yes, I have checked the serial port settings
>> in the coreboot config and they are set to the correct values.
>> So, anyone got a working .config and/or working coreboot.rom I
>> can try? A known working coreboot revision I should download and
>> compile? Or any other tips/pointers?
>> --
>> coreboot mailing list: coreboot at coreboot.org
>> http://www.coreboot.org/mailman/listinfo/coreboot

More information about the coreboot mailing list