[coreboot] ASUS M2V partial success, help needed (Was: Re: ASUS M2V problems)

G tjmadwja at gmail.com
Fri Apr 13 12:05:41 CEST 2012

On Wed, Apr 11, 2012 at 10:48 AM, G <tjmadwja at gmail.com> wrote:
> On Tue, Apr 10, 2012 at 5:26 PM, Marc Jones <marcj303 at gmail.com> wrote:
>> On Tue, Apr 10, 2012 at 7:37 AM, G <tjmadwja at gmail.com> wrote:
>>> Hi,
>>> I'm trying to get coreboot onto my old ASUS M2V (rev. 1.01g)
>>> motherboard, but so far I've had no luck. I'm currently trying to
>>> get the coreinfo payload running, as that seems like the simplest
>>> test case (I've also tried seabios, and failed).
>>> After flashing, when I boot, nothing happens. No beeps, the
>>> monitor remains in power-save mode, the keyboard doesn't respond
>>> to any keypresses (not even holding down several keys for a long
>>> time generates any beeps), no blinking status LEDs, nothing on
>>> the serial port. Nothing.
>>> I've tried with two different revisions, one from 2010-11-24 (the
>>> one that adds S3 support for ASUS M2V), and one from 2012-02-21
>>> (all later revisions fail to compile with lots of different CBMEM
>>> problems).
>>> In the 2010-11-24 revision, I've had to add
>>>       reg++; reg--;
>>> in src/northbridge/amd/amdk8/raminit_f_dqs.c:setup_mtrr_dqs() and
>>>       regm3++; regm3--;
>>> in src/southbridge/via/vt8237r/vt8237_ctrl.c:vt8237_cfg() to get
>>> rid of warnings about unused variables.
>>> Flashing is done by simply running:
>>>       ./flashrom -V -w coreboot.rom -c W39V040C
>>> Does anyone here have any idea what might be wrong? Anyone got a
>>> working .config, tips to use a certain known working revision, a
>>> know working version of flashrom (although flashing two different
>>> versions of ASUS's BIOS using flashrom works well, so I'm
>>> guessing neither flashrom nor my usage of it is to blame), a
>>> working coreboot.rom they can share, or anything else that might
>>> help me move forward?
>>> Using Debian unstable to build, if that's any help.
>>> --
>>> coreboot mailing list: coreboot at coreboot.org
>>> http://www.coreboot.org/mailman/listinfo/coreboot
>> Hi,
>> You will need to capture some output from coreboot to find where your
>> system is having problems.
>> http://www.coreboot.org/FAQ#How_do_I_use_a_null-modem_cable_to_get_coreboot_debugging_output_over_a_serial_port.3F
> Thanks for the reply, but unfortunately, as I wrote in my
> original mail, I get nothing on the serial port.


I've had some partial success, after fiddling around with my
config options. Adding more debug output gives activity on the
serial port, but still nothing on the display and no beeps, or
reactions from the keyboard.

Attached are both my current .config and the output generated
over the serial line, as captured by minicom on another machine.

This is from an ASUS M2V motherboard, with an AMD Sempron 2800+
CPU (family 15, model 79, stepping 2 according to /proc/cpuinfo),
two Kingston KVR667D2N5K2/2G memory sticks (total 2GB RAM), and
an ASUS EAX300LE-A334C/TD (EAX300/TD/P/128M/A) graphics card (I
have also tried with an old ATI PCI MACH64 card from 1996, no

If anyone could tell me what I'm doing wrong, or at least what I
should try next, I'd be grateful.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: minicom.cap
Type: application/octet-stream
Size: 3024 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20120413/6e891983/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config
Type: application/octet-stream
Size: 9379 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20120413/6e891983/attachment-0001.obj>

More information about the coreboot mailing list