[coreboot] ASUS M2V problems

G tjmadwja at gmail.com
Tue Apr 10 15:37:03 CEST 2012


I'm trying to get coreboot onto my old ASUS M2V (rev. 1.01g)
motherboard, but so far I've had no luck. I'm currently trying to
get the coreinfo payload running, as that seems like the simplest
test case (I've also tried seabios, and failed).

After flashing, when I boot, nothing happens. No beeps, the
monitor remains in power-save mode, the keyboard doesn't respond
to any keypresses (not even holding down several keys for a long
time generates any beeps), no blinking status LEDs, nothing on
the serial port. Nothing.

I've tried with two different revisions, one from 2010-11-24 (the
one that adds S3 support for ASUS M2V), and one from 2012-02-21
(all later revisions fail to compile with lots of different CBMEM

In the 2010-11-24 revision, I've had to add
       reg++; reg--;
in src/northbridge/amd/amdk8/raminit_f_dqs.c:setup_mtrr_dqs() and
       regm3++; regm3--;
in src/southbridge/via/vt8237r/vt8237_ctrl.c:vt8237_cfg() to get
rid of warnings about unused variables.

Flashing is done by simply running:
       ./flashrom -V -w coreboot.rom -c W39V040C

Does anyone here have any idea what might be wrong? Anyone got a
working .config, tips to use a certain known working revision, a
know working version of flashrom (although flashing two different
versions of ASUS's BIOS using flashrom works well, so I'm
guessing neither flashrom nor my usage of it is to blame), a
working coreboot.rom they can share, or anything else that might
help me move forward?

Using Debian unstable to build, if that's any help.

More information about the coreboot mailing list