[coreboot] Porting Asus A8V-VM: Problem with initializing the SuperIO

Nikolai Spassoff ns at codingrobot.com
Sun Sep 18 15:51:48 CEST 2011

After getting a POST-card I managed to get the serial output running.
COM1 is actually mapped to SP2.

Now I ran into a problem initializing the SDRAM, particularly
sdram_initialize() in (src/lib/generic_sdram.c)
The function hangs right before entering the first loop body. A POST
code right before the for-loop gets displayed and
a code within the loop doesn't. The value of the controllers var. is
1, so the loop should be entered only once.

I also tried removing the loop, as the body needs to be executed only
once, and coreboot stopped on sdram_set_registers()

Output from the serial console: http://codepad.org/pXamBs0O
and here is a link to my current romstage.c http://codepad.org/uhTV06GU

I also attached the dir. containing all mainboard-related files.

On Fri, Aug 26, 2011 at 10:10 PM, Rudolf Marek <r.marek at assembler.cz> wrote:
> Hi,
> Try changing ROMSTRAP if the M2V-MX SE works than it might be this. Go to
> the src/southbridge/via/romstrap.inc and change the romstrap to use the
> K8T890 instead of K8M890. I think both differs only in one byte 0xaa versus
> 0xff
> In other words check if with changed ROMSIP something changes. I guess this
> is the only remaining difference between the SerialICE and coreboot.
> Let me know if this works for you.
> Thanks
> Rudolf
-------------- next part --------------
A non-text attachment was scrubbed...
Name: a8v-vm_se.zip
Type: application/zip
Size: 33124 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20110918/4f6d9363/attachment.zip>

More information about the coreboot mailing list