[coreboot] Issues with Supermicro H8SCM

Thomas Gstädtner thomas at gstaedtner.net
Sun Oct 9 17:53:08 CEST 2011

On Sun, Oct 9, 2011 at 07:17, She, Kerry <Kerry.She at amd.com> wrote:
> Hello, Thomas
>> -----Original Message-----
>> From: coreboot-bounces+kerry.she=amd.com at coreboot.org [mailto:coreboot-
>> bounces+kerry.she=amd.com at coreboot.org] On Behalf Of Marc Jones
>> Sent: Saturday, October 08, 2011 3:45 AM
>> To: Thomas Gstädtner
>> Cc: coreboot
>> Subject: Re: [coreboot] Issues with Supermicro H8SCM
>> On Fri, Oct 7, 2011 at 1:10 PM, Thomas Gstädtner <thomas at gstaedtner.net>
>> wrote:
>> >
>> > Thanks for the advice Marc,
>> >
>> > I already had the loglevel set to spew (8). I additionally tried the
>> > other "Verbose output" debugging options, unfortunately I don't get
>> > any output at all when they are built in.
>> > Also, while it is hard to find and AMD doesn't have any official
>> > document confirming this, according to some google hits the processor
>> > should be revision D1 not rev E (AMD model number: OS4170OFU6DGOWOF ).
> I also found the latest code not boot on my H8SCM-F mainboard with Rev D1 processor.
> So I have made some update to using the AGESA wrapper framework,
> the attachment is some of my update,
> with this series of patches applied, we can boot to Debian Linux Destop or
> Windows Server 2008 R2 standard edition.
> Thanks

Hi Kerry,

first of all: thanks for your effort!
While I had no success at first, I now can get to the boot prompt
(haven't tried any further yet).

Anyway, I currently have 2 DIMMs, each 4 GiB.
A dual-channel configuration does not seem to work, the DIMMs are
detected, but coreboot throws an "ASSERTION FAILED" error (see
attached log cb_h8scm_01.log).
It seems to fail because it somehow seems to think no DIMM is found
(despite both DIMMs being detected). I tried disabling this check, but
this only leads to a reset.
The same problem exists with a single-DIMM configuration.

However, when I switch to a dual-DIMM, single-channel config, it at
first does not start at all (i.e. no output on serial and no heartbeat
from the BMC) - but when I trigger a manual reset it immediately
starts up (see attached log cb_h8scm_dimma1a2_success.log).

I'll report back when I find out more.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cb_h8scm_01.log.gz
Type: application/x-gzip
Size: 836 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20111009/077564ab/attachment.gz>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cb_h8scm_dimma1a2_success.log.gz
Type: application/x-gzip
Size: 10023 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20111009/077564ab/attachment-0001.gz>

More information about the coreboot mailing list