[coreboot] Issues with Supermicro H8SCM

Thomas Gstädtner thomas at gstaedtner.net
Wed Oct 5 01:26:42 CEST 2011

Hi everyone,

I own a Supermicro H8SCM-F-O mainboard (AMDs SP5100 Chipset), one of
the boards AMD as of recently claims to officially support.
So I decided to try coreboot, but (as expected) it is not really an
out-of-the-box experience.

First of all, flashrom does not support flashing out-of-the-box, but
Frederic Temporelli's patches (
http://patchwork.coreboot.org/patch/3326/ and
http://patchwork.coreboot.org/patch/3326/ ) work fine for me (I tested
multiple reads and multiple writes, always worked), I can report that
to the flashrom list separately if you want.

I built coreboot from the gerrit-branch (also tried a "stable"
revision), coreboot-4.0-1714-gf8adf7a, using the "default"
board-config incl. seabios (stable) as payload.
After powering on nothing happens (apart from the fans running and the
power led flashing) and it stays that way, it is silent on VGA as well
as serial.
After manually triggering a reset I immediately get the following
output on serial:

coreboot-4.0-1714-gf8adf7a Wed Oct  5 00:31:05 CEST 2011 starting...
BSP Family_Model:

Here it hangs, and I don't quite know how to move on and debug the issue.

Can you give me any hints where to go on from here? I have external
flashing equipment at hand (which also works fine btw.), but no fancy
bios-debugging hardware.



P.S. In case anyone else stumbles upon it: the board has 2 separate
flash chips, one Macronix MX25L12845E with 128 Mbit (the SOIC16W
package on the left of the board) as well as a SST25VF016B, 16 Mbit,
as the SOIC8W on the right. The first one holds the IPMI firmware, the
second one the AMI BIOS.
Flashing requires a testclip or some really serious soldering skills.
Attaching a SO8 socket can only be done with hot air soldering.

More information about the coreboot mailing list