[coreboot] RE : [PATCH] Re: RE : RE : First coreboot build for Tyan s2895 K8WE mobo with seabios payload, computer starts, but graphical ubuntu 64bits is crashing

STEMMELIN, FREDERIC (FREDERIC)** CTR ** frederic.stemmelin at alcatel-lucent.com
Sun Sep 19 15:35:26 CEST 2010

Thank you very much for your help, in the mean time i have very goods news, yes my Tyan s2895 is BOOTING now :)

I found what was the origin of teh crashes after i was trying to boot a debian livecd with "noapic noapm" and such other things as kernel parameters (i didnt change the defaut settings).
I saw a kerneloops on screen after kernel was trying to set a IRQ for the intel network card, with error -39 (or -38 i dont remember exactly).

Now after remowing my Intel PRO1000MT server network card from PCI-X slot 6, i can boot without any problems :)
Memtest86+ v 4.0 is still not working, but less important now that i am sure my problem was not RAM related :)
I will anyway try your instructions with patchs and report back.

By the way, i was not able to compile following with coreboot v4:
- corinfo => compile errors
- tint => same
- memtest as payload => same

I tried several things like changing Makefile, but it didnt work as i dont understand what it doest exactly.

Thank's for your support.

PS: If needed i can provide all informations what mayy necessary to find the PCI-X bug with teh network card, if you wish.

De : Juhana Helovuo [juhe at iki.fi]
Date d'envoi : samedi 18 septembre 2010 18:23
Cc : coreboot at coreboot.org
Objet : [PATCH] Re: [coreboot] RE : RE : First coreboot build for Tyan  s2895 K8WE      mobo    with seabios payload, computer starts, but graphical ubuntu     64bits  is crashing

On Sat, 2010-09-18 at 00:14 +0200, STEMMELIN, FREDERIC (FREDERIC)** CTR
** wrote:
> In the mean time i checked RAM with memtest86+ v4.0 provided with
> Ubuntu 10.04, and it is not working at all, 0kb RAM detected with
> coreboot+seabios.
> On tyan bios all the RAM is detected properly (no errors on tests
> too).
> I have 4*2GB ECC RAM from crucial, dont remember ref, can probably find it somewhere.


My guess from your memtest86+ printouts is the following:

With Tyan BIOS, memtest86+ uses BIOS call "e820" to find out the
available RAM.

With Coreboot + SeaBIOS, memtes86+ detects that there are Coreboot
tables in memory ("LxBIOS"), but for some reason thinks that the table
reports 0k memory. This may be because your memtest86+ version does not
support Coreboot "high tables", and therefore detects the presence of
Coreboot, but cannot read the contents of the table.

Coreboot does not implement the e820 interface, but SeaBIOS should have
it available. However, when memtest86+ detects that Coreboot is present,
it ignores the e820 interface and tries to read the Coreboot tables.

I have made a patch for memtest86+ v4.10, which adds better support for
Coreboot and also multiboot tables. The patch is not my original work,
but a combination of two patches, so the credit belongs to the original

Application instructions:

* Download memtest86+ v 4.10 sources .tar.gz and untar

* Apply patch, e.g. patch -p1 < ../coreboot-v4-and-multiboot-support-for-memtest86+-4.10.patch

* Manually rename two files:
% mv linuxbios.c coreboot.c
% mv linuxbios_tables.h coreboot_tables.h

* Build memtest86+ using "make"

The build process creates two versions of the memtest86+ binary.
"memtest" is multiboot-compatible ELF executable and "memtest.bin" is
bootable image like a Linux kernel image. Choosing between these two
depends on your boot method: BIOS, Coreboot only, Coreboot+SeaBIOS, or a

My success with memtest86+ has been rather limited, but maybe this works
for you.

Best regards,
Juhana Helovuo

More information about the coreboot mailing list