[coreboot] RE : First coreboot build for Tyan s2895 K8WE mobo with seabios payload, computer starts, but graphical ubuntu 64bits is crashing

STEMMELIN, FREDERIC (FREDERIC)** CTR ** frederic.stemmelin at alcatel-lucent.com
Fri Sep 17 23:01:03 CEST 2010


I have tried many things since last time, but still no luck so far.
I first checked the system logs to try to find the reason of last system crash (computer freezing) which do not occur with tyan stock 1.06 bios, and here is what i found out (/var/log/messages):

Sep 16 21:22:51 tyan kernel: [    0.676939] pci 0000:00:07.0: hash matches
Sep 16 21:22:51 tyan kernel: [    2.170702]  sda:
Sep 16 21:22:51 tyan kernel: [    2.193411]  sda1 sda2
Sep 16 21:22:51 tyan kernel: [    2.429232] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
Sep 16 21:22:51 tyan kernel: [    2.429236] EXT4-fs (sda1): write access will be enabled during recovery
Sep 16 21:22:51 tyan kernel: [   15.260291] EXT4-fs (sda1): recovery complete

I dont know what the hash matches could be, and partition table result is listed on two different lines.
More important in the ext4 recover from a fsck, which i have often with coreboot + seabios (i my many trials).
I dont had a single fsck with stock bios, so it must be somehow related to seabios or coreboot, at least i think so.

After that, i burned a new coreboot bios with latest prebuild seabios payload, and changed only two settings with "make menuconfig":

I set => "Use VGA console once initialized"   i was hoping not be blind anymore during boot up (before kernel booting)
unset => "GDB debugging support"              i guessed that boot speed would be increasing, but it was not the case.

I changed then 2-3 things in file /etc/default/grub (the 'update-grub'), to see serial outout during booting and also after booting:

GRUB_CMDLINE_LINUX_DEFAULT="text console=tty0 console=ttyS0,115200n8"
GRUB_SERIAL_COMMAND="serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1"

The text part was to avoid a graphical start of Ubuntu, but computer is still freezing, and the rest if for serial output.
I captured the serial output from another computer with null modem cable and 'screen -L /dev/ttyS0', which produced the screenlog file that i attached i this email.

I also created the file "/etc/init/ttyS0.conf" with following content, to try to be able to login over serial, just for testing (which is working fine with stock bios):

# ttyS0 - getty
# This service maintains a getty on ttyS0 from the point the system is
# started until it is shut down again.

start on stopped rc RUNLEVEL=[2345]
stop on runlevel [!2345]

exec /sbin/getty -L 115200 ttyS0 vt102

But, computer is freezing after message about apparmor stuff (dont know if it is related or not).
Login over serial port is not possible, computer completely frozen.

So i have a few questions again:
- what does actually the option 'Use CMOS for configuration values' ?
- if y press F12 (what i didnt so far) and may be change some settings (i dont know if it is possible), will it overwrite my current cmos config, which i would like to keep as it is properly configure for my stock bios ?
- should i may be try another linux distribution, like Debian to check if my problem is kernel related, or even boot from a ext3 FS ?

Thank you for your help.

PS: Now i know why the seabios or coreboot takes longer to boot, because of RAM cleaning (thank's to serial output), and of course i made a 'make clean with rm -rf build nad rm .option before building new coreboot with prebuilt seabios.
De : Myles Watson [mylesgw at gmail.com]
Date d'envoi : vendredi 17 septembre 2010 17:08
Cc : coreboot at coreboot.org
Objet : RE: [coreboot] First coreboot build for Tyan s2895 K8WE mobo with seabios payload, computer starts, but graphical ubuntu 64bits is crashing

> > GRUB_CMDLIN_LINUX_DEFAULT="verbose" in /etc/default/grub and "sudo
> update-> grub"
> I will do it, with original VGA bios and prebuild seabios too.
Since there's no built-in video card on the s2895, there shouldn't be a VGA
BIOS for the board.  I was thinking of the s2892.

My s2895 boots fine, so when you get a log & send it to the list, we should
be able to figure out what's going wrong pretty easily.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: screenlog_17092010_coreboot_seabios_prebuilt_text_mode.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20100917/6ee26921/attachment.txt>

More information about the coreboot mailing list