[coreboot] [PATCH] Add support for Asus M4A785-M, with build instructions

Myles Watson mylesgw at gmail.com
Sat Sep 11 15:03:10 CEST 2010

> I tried the patches you sent just now. Since Socket/DIMM type
> configuration was changed in rev 5800, I tested these against rev 5799.
> Patching and building is ok. Booting looks fine, Grub2 comes up and
> loads Linux. However, Linux cannot find SATA controller, and because of
> that, the booting fails. (Although Grub just loaded the kernel and
> initrd from SATA.)
> Linux gives the following complaints that I have not seen before:

> It seems that also the USB controller initialization fails, although I did not test if it worked.

> Aside from the AHCI/OHCI/EHCI -drivers failing, the boot logs seem to be the same as before.
> I tried to look at the patch code, but could not figure out why this is happening.

So it works with my updated patch, but not with the uma & reserved
patches?  Or does it not work at all?  Does it still work with your
previous patch set?

Could you send a full log with the last working version and the first
broken version from this list?

1. Your original patches
2. 5799 + my board patch
3. 2 + uma.diff
4. 3 + reserved.diff

uma.diff & reserved.diff should be independent, so you could try
2+reserved.diff also

I attached an updated patch that should apply to 5800 if that's easier/better.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: asus-m4a785m-small-patch.patch
Type: text/x-diff
Size: 17276 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20100911/3e40cccc/attachment.bin>

More information about the coreboot mailing list