[coreboot] AMD AP core startup problem

Patrick Georgi patrick at georgi-clan.de
Tue Oct 12 08:59:09 CEST 2010

Am 12.10.2010 06:08, schrieb Scott Duplichan:
> I find with my RS780/SB700 board (ECS A780GM-M3), the initial
> family 10h AP launch is not reliable. I often see a hang when
> when all the cores are running in parallel. The parallel execution
> is apparent if serial logging is enabled, because the characters
> logged by each core are interleaved. I noticed the AP cores do a
> few cf8/cfc pci config writes. Could simultaneous access to this
> shared index/data pair be responsible for the hang? Concerns about
> such conflicts is why the AMD agesa code does not run cores on the
> same die in parallel.
This probably happens in the code that determines the CPUID, right?
I worked around this by reading until the CPUID is != 0xffffffff (which
is an invalid value, but the value that a failed read returns). It's a
hack, but it worked for me.


More information about the coreboot mailing list