[coreboot] PCI register read/mod/write code

Warren Turkal wt at penguintechs.org
Mon Oct 4 06:38:32 CEST 2010

On Sun, Oct 3, 2010 at 4:39 PM, Carl-Daniel Hailfinger
<c-d.hailfinger.devel.2006 at gmx.net> wrote:
> May I suggest alternative names:
> pci_and8(), pci_or8()
> pci_and_config8(), pci_or_config8()

I am sure this it bike shedding, but here are a few other options for
the name scheme:
* pci_bit_and8()
* pci_bitwise_and8()
* pci_bit_andb()
* pci_bitwise_andb()

I am waffling between preferring pci_bitwise_andb() or
pci_bitwise_and8() for readability.


More information about the coreboot mailing list