[coreboot] K8+RS780+SB710 board failed to boot linux with 4G DRAM

Scott Duplichan scott at notabs.org
Tue Nov 23 01:38:33 CET 2010

-----Original Message-----
From: Liu Tao [mailto:liutao1980 at gmail.com] 
Sent: Monday, November 22, 2010 04:50 AM
To: coreboot at coreboot.org
Cc: Scott Duplichan; mrtadis at gmail.com; wangqingpei at gmail.com; Zheng.Bao at amd.com
Subject: K8+RS780+SB710 board failed to boot linux with 4G DRAM

Hello all,

I'm porting coreboot on a K8+RS780+SB710 board, the board is similiar
with AMD's mahogany board in hardware routing, the major difference is
my board has RS780/SB710 on CPU's HT chain1, not the default chain 0.

My porting work is based on the mahogany code in official tree, the major
changes including:

1) configure device/resource map to point out southbridge is on ht chain 1
2) fix hard-coded ht chain0 mmio in RS780 configuration codes (committed r5959)
3) board related MPTABLE/ IRQTABLE/ ACPI_routing configurations

I use seabios to boot RHEL 5.5 X86_64 system on my SATA disk, which
connects at SB710's SATA port 0.

With 2G DRAM, the system boots and works fine, but with 4G DRAM, the
system failed to detect the SATA disk and repeats waiting. I tried mem=4g
param with 4G DRAM, that works, but wasts memory mapped to 4G above.

I have tried disable UMA and Integrated Graphics, disable GART, use soft
iommu in kernel, and noapic/nolapic/noacpi/noapm/acpi=off kernel params,
all has no effect with the problem.

Attached is the coreboot+kernel boot log,  for 4G DRAM with/without
mem=4g param, any suggestion is welcome, thanks.

Liu Tao

Hello Liu Tao,

I found a linux mint 9 live CD can reproduce this problem. It happens on both mahogany and mahogany_fam10. I didn't find any obvious
problem that could cause this. I may try again later,
because Win7 is not yet working with this memory configuration either.


More information about the coreboot mailing list