[coreboot] SATA/IDE failed under 64bit linux

Tadas S mrtadis at gmail.com
Mon Nov 15 14:49:00 CET 2010

Hi, have you tried adding "rootdelay=90" or similar to the GRUB's kernel
line? Also try adding "nolapic" or "noapic" or "noacpi" or "noapm".

2010/10/26 Liu Tao <liutao1980 at gmail.com>

> Hello all,
> I'm using coreboot4 + seabios to boot a K8/RS780/SB710 based board,
> my SATA disk and DVD-drive connects to SB710's SATA0/SATA1 port.
> Now the board can boot Ubuntu-10.10-i386 and FedoraCore-13-i686, and
> everything seems ok, but with 64bit linux OS, including SUSE11-X86_64/
> RHEL5.5-X86-64/ Ubuntu-10.10-X86_64, the SATA drive cannot be recognized,
> the kernel reports "qc time out" during SATA disk scanning, and randomly
> crashes during this process.
> I checked the mptable and confirmed the IRQ of ahci is correct. With
> pci=nomsi
> parameter, the 32bit kernel boots and works fine, 64bit kernel uses the
> same
> irq number and can't detect SATA disk correctly. Without pci=nomsi, 32/64
> bit
> kernel may use different MSI irq number, but the result is same, 32bit ok
> and
> 64bit fail.
> Later I tried to install 64bit linux with IDE harddisk/DVD, seabios
> successfully
> boots the installation DVD, but linux can't find any CD-ROM & harddisk.
> The installation script can eject the DVD-drive, but it can't find the
> device file
> to mount and reports no CDROM detected, so the installation can't continue.
> I think maybe something is wrong with ACPI or other tables bios provides to
> linux kernel? I'm not familia with the bios/kernel interaction, does anyone
> has
> any suggestions on the problem? Thanks very much!
> --
> Regards,
> Liu Tao
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20101115/37ef6de8/attachment.html>

More information about the coreboot mailing list