[coreboot] unable to boot linux with coreboot

mbertens mbertens at xs4all.nl
Sun Jun 13 11:30:19 CEST 2010

Hi all,

an update:
I installed a secondary build system (ubuntu), i build everything from
scratch; seabios and coreboot r5575, r5600 and r5631, all these where
working fine. But booting them all failed. 

I tried  everything i could think of;
1. Swapped hardware; memory, system board, harddisks, ide-controller
(pri. versus sec.).
2. Swapped development systems (debian versus ubuntu)

I attached two bootlogs. for analise 
1.	with 80Gb harddisk.
	- up to 7 secs in the boot process all is fine
	- then 120 secs of silence, and last the message from udevd
2.	with 1Gb compact flash disk (which has a DMA problem, but its able to
boot futher in the Linux boot secuence.
	- up to 6 secs in the boot process all is fine
	- then 120 secs are lost to the DMA problem of the CF card, the system
booted before with de DMA failures just fine it takes only 120 secs
	- then 120 secs of silence, and the message from udevd
	- then some more output on starting the cardbus and others.
	- final message adding the swap on /dev/hda5 and then silence again.

I hope that anyone can help me with this silly problem, please don't
just throw a term through the mail, like "fix the DMA problem", but give
some pointers how to solve it in my configuration.


On Fri, 2010-06-11 at 20:43 +0200, mbertens wrote:
> On Thu, 2010-06-10 at 12:31 -0600, Myles Watson wrote:
> > > >> > Anyone any ideas
> > Have you tried to boot the factory BIOS?  Are these all cold boots?  Did
> > cold boot always work?
> > 
> > Thanks,
> > Myles
> > 
> I have two systems here on the table;
> 1.A.	original BIOS (insyde) boots just fine with FreeBSD
>   B	with external ROM on the JDEBUG connector (see
> http://www.coreboot.org/Tutorials:Nokia_IP530#J-DEBUG ) im not able to
> boot coreboot (R5628 or 5600 with my patches which worked before). 
> 2.	The on-board flash contains R5512 that does not boot as well and this
> one booted before too.
> So as you can understand i'm a little lost
> I tried adding bayou with payloads seabios and coreinfo, seabios is
> starting as before, but coreinfo doesn't do anything.
> Marc  	
-------------- next part --------------
A non-text attachment was scrubbed...
Name: putty-ip530-13-jun-2010-r5631.log
Type: text/x-log
Size: 54435 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20100613/56760128/attachment.log>

More information about the coreboot mailing list