[coreboot] Memtest86+ failing on coreboot system.

Knut Kujat knuku at gap.upv.es
Mon Jan 25 17:36:03 CET 2010

Patrick Georgi escribió:
> Am 25.01.2010 17:13, schrieb Knut Kujat:
>> Hi,
>> I would love to send the new board to the list but there are several
>> issues still remaining like:
>> - SMBus gets irq 0 instead of 5
>> - ACPI not working
> We have lots of boards with (at best) incomplete ACPI support. That
> shouldn't stop you from releasing :-)
>> - booting interrupts for about 4 minutes on "Stage: loading
>> fallback/coreboot_ram @ 0x200000 (360448 bytes), entry @ 0x200000"
> You could try to dump the MTRRs right before loading the ramstage. 4
> minutes sounds like there's some problem with caching.
>> and the strangest thing: I created a new folder h8qme_fam10 (I was
>> working in h8dmr_fam10 all the time)  made the different changes to be
>> able to compile everything correctly and now it refuses to boot. It just
>> halts somewhere or does several soft resets at different places.
> Did you check that there is no h8dmr_fam10 or H8DMR_FAM10 in the new
> directory? Is that directory hooked up in kconfig (if you're using
> kconfig, that is)?
> If you mix up the names, it might just build a mix of code for your
> board and another supermicro board.
> Patrick
I was very careful with not mixing names. I tried to just rename the
existing folder as well with the same result, it's just so annoying
because I know I must be forgetting something really stupid.

Knut Kujat.

More information about the coreboot mailing list