[coreboot] [RFC] simplify names

Peter Stuge peter at stuge.se
Mon Dec 6 18:36:45 CET 2010

Stefan Reinauer wrote:
> The sb700_ prefix was introduced in the early v2 tree many years ago
> because our old build system "newconfig" could not handle two files with
> the same name in different paths like /path/to/usb.c and
> /another/path/to/usb.c correctly. Only one of the files would end up
> being compiled into the final image.
> Since Kconfig (actually since shortly before we switched to Kconfig) we
> don't suffer from that problem anymore. So we could drop the sb700_
> prefix from all those filenames (or, the <componentname>_ prefix in general)
> - makes it easier to fork off a new chipset
> - makes it easier to diff against other chipsets
> - storing redundant information in filenames seems wrong
> Signed-off-by: <stepan at coresystems.de>

Acked-by: Peter Stuge <peter at stuge.se>

More information about the coreboot mailing list