[coreboot] K8 SMP broken?

Myles Watson mylesgw at gmail.com
Fri Aug 13 18:01:43 CEST 2010

On Fri, Aug 13, 2010 at 2:20 AM, Torsten Duwe <duwe at lst.de> wrote:
> On Thursday 12 August 2010, Myles Watson wrote:
>> > has anybody tested K8 SMP recently?
>> In this thread:
>> Re: [coreboot] DL145 G1 with dual dualcore CPU using coreboot ?
>> Oskar is testing K8 SMP.  It seems to work for him.
> Thank you Myles, good point.
>> He's basing his port
>> off the s2881.  Maybe you could compare the s2881 and s2885 code.
> I have reordered romstage.c to match the 2881; still no go. Maybe something
> with the HT setup.

You could send the early log to see if we can spot something.

I just tried SimNOW (serengeti_cheetah), and it works with two
single-core CPUs.  The only thing I thought of was maybe you should
change CONFIG_APIC_ID_OFFSET to 0.  It seems like the problem may be
ID confusion if it's trying to stop something that isn't responding?
I'm not sure at all, but I don't think it will hurt to try.

Good luck,

More information about the coreboot mailing list