[coreboot] [PATCH] continue cleaning up log levels

Myles Watson mylesgw at gmail.com
Sat Apr 3 00:44:42 CEST 2010

>> The whole intent was to make clear to the reader that this is something
>> that's never seen. ;-)
>> That doesn't become clear from BIOS_SPEW+1 in my opinion.
> NEVER was only used once or twice in the code.  If it's something that will
> be used more often, then I can see your point.  Why don't we just comment
> out messages that will never be seen?

I just looked again, and it was only used once.  It makes sense where it was
used, but I don't think it makes sense to use it other places, and I think
naming it with the same prefix and including it in the same list makes that
likely in the future.

I think a comment explaining BIOS_SPEW+1 would work just as well, or this:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20100402/f327ed8e/attachment.html>

More information about the coreboot mailing list