[coreboot] SMP Linux on QEMU

Jen-Cheng(Tommy) Huang tommy24 at gatech.edu
Sat Sep 12 01:10:50 CEST 2009

Thanks for the response.
No, I didn't modify it.The qemu version is 0.10.5.
coreboot version is the latest one.
And I used the method mentioned in
<http://www.coreboot.org/QEMU_Build_Tutorial>I can build successfully. But
the resulting bios still crashed.
But I think even in v2, I still can't see multiple cpus in OS.
Since "-smp n" is only recognized by qemu, coreboot won't generate
corresponding MP table.
So Linux won't be able to see multiple cpus.
I am still trying how to make linux see multiple cpus if I use FILO.
Any information is appreciated.

On Fri, Sep 11, 2009 at 3:41 PM, Myles Watson <mylesgw at gmail.com> wrote:

> On Thu, Sep 10, 2009 at 6:26 PM, Jen-Cheng(Tommy) Huang <
> tommy24 at gatech.edu> wrote:
>> Hi,
>> I am using coreboot v3 with FILO.
>> I specify "qemu -L . vd.img -smp 4".
>> But I always see one cpu in /proc/cpuinfo.
>> Then I tried if SMP works in v2.
>> However, when I tried to boot, qemu showed the following error messages:
>> (v3 works fine here)
>> CBFS: follow chain: fff9b800 + 28 + 547d8 + align -> ffff0000
>> CBFS:  Could not find file normal/coreboot_ram
>> Jumping to image.
>> qemu: fatal: Trying to execute code outside RAM or ROM at 0x000a0000
> Have you modified it?  I just tried the latest from svn, and I don't get
> that error.
> Myles
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090911/b6b55c4d/attachment.html>

More information about the coreboot mailing list