[coreboot] SMP Linux on QEMU

Jen-Cheng(Tommy) Huang tommy24 at gatech.edu
Fri Sep 11 02:26:51 CEST 2009

I am using coreboot v3 with FILO.
I specify "qemu -L . vd.img -smp 4".
But I always see one cpu in /proc/cpuinfo.
Then I tried if SMP works in v2.
However, when I tried to boot, qemu showed the following error messages: (v3
works fine here)
Uncompressing coreboot to RAM.
Jumping to image.
Check CBFS header at fffeffe0
magic is 4f524243
Found CBFS header at fffeffe0
Check fallback/payload
CBFS: follow chain: fff80000 + 38 + 14efa + align -> fff94f40
Check fallback/coreboot_ram
CBFS: follow chain: fff94f40 + 38 + 687f + align -> fff9b800
CBFS: follow chain: fff9b800 + 28 + 547d8 + align -> ffff0000
CBFS:  Could not find file normal/coreboot_ram
Jumping to image.
qemu: fatal: Trying to execute code outside RAM or ROM at 0x000a0000
Does anyone know how to boot up SMP kernel on qemu?
Any hint is very appreciated.
Thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090910/66009aa8/attachment.html>

More information about the coreboot mailing list