[coreboot] [PATCH] Add kconfig menus for most chipset VIDEO_MB values

Uwe Hermann uwe at hermann-uwe.de
Mon Oct 26 22:49:03 CET 2009

On Mon, Oct 26, 2009 at 02:26:36PM -0600, Myles Watson wrote:
> On Mon, Oct 26, 2009 at 2:14 PM, Uwe Hermann <uwe at hermann-uwe.de> wrote:
> > See patch.
> >
> I liked the correspondence between the devices menu and src/devices.  Maybe
> some other name would be better for the top-level menu?  I don't think
> miscellaneous is really what we want to say for src/devices.

The best I could come up with so far is "Chipset" for the top-level menu
and leaving the "Devices" subsection intact. I'm happy about suggestions
for better names.

> I think it's pretty ugly to have 512 be the value for CONFIG_VIDEO_MB that
> means 512K.  I know you didn't do that, but...  Maybe we could just say the
> 512K of RAM doesn't make that much difference and make the minimum 1MB?

Yeah, the 512KB thing is not really nice, but there's not much we can do
about it. We could turn VIDEO_MB into VIDEO_KB instead to have the same
unit everywhere, not sure if that's nicer or uglier.

I don't want to leave out valid options supported by the hardware
though, so the 512KB setting should stay. I think it's not _that_ big
of a problem as the uglyness is only visible to the developers of
two chipsets I think (i810 and i830), but not to the other developers
and especially not to the user (who sees nice menuconfig entries).
We can leave it as is IMHO.

> With the menu names fixed:
> Acked-by: Myles Watson <mylesgw at gmail.com>

Thanks, r4866.

libv mentioned on IRC that cn400 and cn700 values may be wrong, can
somebody with datasheets please verify/fix them? Or maybe they can be
extracted from unichrome at


but I wasn't able to find the values after a quick glance (more detailed
checking is probably needed).

http://www.hermann-uwe.de  | http://www.randomprojects.org
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org

More information about the coreboot mailing list