[coreboot] coreboot hangs on my AMD fam10 board.

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat Oct 10 03:16:13 CEST 2009

On 09.10.2009 08:10, Bao, Zheng wrote:
> Current coreboot seems to hang somewhere. Before the 60th anniversary of
> People's Republic of China, I always disable the CBFS when I worked on
> my fam10 board, otherwise it would be error. But now, I can not find
> where I can disable it. It seems to stop at waiting AP cores. 
> I am wondering if it is caused by CBFS and if it happens on other board.
> If any one can test it, I will be appreciating.

We have not solved the SMP startup printk locking yet. That explains the
mangled log messages.
Unless I'm mistaken we still decompress some parts multiple times
concurrently to the same address and that can crash the code.
Overlapping stack might also crash the code during lzma decompression.
Decompression of AP code should happen on the BSP or on exactly one AP,
but not on all APs.

> coreboot-2.0.0-r623M_tilapia_fam10_Fallback Fri Oct  9 13:15:49 CST 2009
> starting...
> [...]
> Start other core - nodeid: 00  cores: 03
> started ap apicid:    cccooorrreeexxx:::      ---------   {{{
> IIIDDD   ===   000312   NNNOOODDDEEEIIIDDD   ===   000000
> CCCOOORRREEEIIIDDD   ===   000321}}
> }   ---------


Developer quote of the week: 
"We are juggling too many chainsaws and flaming arrows and tigers."

More information about the coreboot mailing list