[coreboot] #137: S2895 no function after coreboot 2 flash

Myles Watson mylesgw at gmail.com
Mon May 18 22:01:54 CEST 2009

>  I am not sure whether i am correct here with you guys. But i have some
>  troubles after flashing the tyan-s2895.rom that has been generated with
>  seabios as payload by the buildrom tool.
>  There are no logs in the log folders and everything worked fine.
>  But after flashing the coreboot bios to the board using "flashrom -v -w
>  tyan-s2895.rom" and i "halt" the system, it will come up for a second and
>  switches off immediately. I tried clearing the CMOS, but this did not
>  solve the problem.
>  Any idea what i am doing wrong?

I built an s2895 image just now from buildrom and there is serial output,
the display gets initialized, and then it breaks because the version of
coreboot is so old in buildrom.  Buildrom still uses r3259 for s2895, and a
lot has changed since then.

Hopefully you have a way to get your machine back.  I like the pushpin
method of changing the ROM chips.


More information about the coreboot mailing list