[coreboot] [PATCH] flashrom: Use chipaddr_t instead of volatile uint8_t *

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat May 16 23:23:46 CEST 2009

On 16.05.2009 20:06, Uwe Hermann wrote:
> On Sat, May 16, 2009 at 04:29:14AM +0200, Carl-Daniel Hailfinger wrote:
>> chipaddr is my favourite, though, because our accessor functions are
>> named chip_read* and chip_write* and this would give us some naming
>> consistency. Of course, said consistency can also be achieved by
>> renaming the chip accessor functions to flash_read* and flash_write*.
>> The name is a not important for me as long as we can kill volatile
>> uint8_t * with it.
>> :-)
>> Do you want me to resend, and with which name?
> I'd say let's use flashaddr for now, but IMHO either name is fine.
> Acked-by: Uwe Hermann <uwe at hermann-uwe.de>

Thanks, committed in r519.

Apologies to everyone who has to readjust his/her patches against the tree.



More information about the coreboot mailing list