[coreboot] SeaBIOS, serial output, and grub

Ward Vandewege ward at gnu.org
Wed May 13 16:46:11 CEST 2009

On Tue, May 12, 2009 at 11:04:07PM -0400, Kevin O'Connor wrote:
> On Tue, May 12, 2009 at 08:16:47PM -0400, Ward Vandewege wrote:
> > I'm seeing the exact same issue on m57sli (which is also mcp55 based,
> > however). Has anyone else tried coreboot + SeaBIOS + grub with serial?
> This looks to be an issue with SeaBIOS serial port detection.  Can you
> retry with the latest seabios git?  Make sure CONFIG_SERIAL is enabled
> in SeaBIOS as grub relies on the serial ports being detected by the
> bios.

That was with seabios as of Monday 2009-05-11.

But - I just tried on both h8dme and m57sli with Seabios head as of today,
and the bug appears to be gone! Did you change something?

The only thing that's not working for me yet is getting Seabios itself output
on serial, via sgabios. I'm looking at that now.


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior Systems Administrator

More information about the coreboot mailing list