[coreboot] r4233/4234 broke h8dme (serial corruption + hang)

Patrick Georgi patrick at georgi-clan.de
Sun May 3 09:42:52 CEST 2009

Am 03.05.2009 02:40, schrieb Ward Vandewege:
> On Sat, May 02, 2009 at 04:38:12PM -0700, ron minnich wrote:
>> On Sat, May 2, 2009 at 2:58 PM, Ward Vandewege<ward at gnu.org>  wrote:
>>> On Sat, May 02, 2009 at 01:42:34PM -0700, ron minnich wrote:
>>>> It does look like an SMP machine in which both CPUs are trying to run
>>>> as the BSP.
>>>> Possible?
>>> It's definitely an SMP machine, two dual-core CPUs.
>> So can you see what changed in the k8 north/cpu support since the last
>> time it worked?
> Sure. The last time it worked is r4232, I had to bisect to find the commit
> causing the problem. r4233/4234 are one changeset.
> src/northbridge/amd is unchanged by this changeset.
> The diff for src/cpu/amd is attached.
The various copies of "copy_and_run" were merged into
I tweaked the coreboot_apc generation a bit, by adding the serial driver 
and console output code. It worked on a fam10 board here, so I didn't 
think it to cause much trouble - seems like it does.

The interleaved messages are

(by the BSP)
malloc Enter, size 1100, free_mem_ptr 00148000
malloc 00148000

(by the AP)
image length = 00002a6c
Jumping to image.

That's definitely a different image used for the AP than the one for the 
BSP (see image length some lines earlier)


More information about the coreboot mailing list