[coreboot] Strange failure - help?

Myles Watson mylesgw at gmail.com
Wed Mar 18 19:17:15 CET 2009

On Tue, Mar 17, 2009 at 3:27 PM, Myles Watson <mylesgw at gmail.com> wrote:
> I have two coreboot trees.  As far as I can tell they're identical.
> One produces working ROM images, and the other reboots when it jumps
> to the payload.
> These are the only differences from the .map files:
> Broken:
> 0000b03d A _binary_coreboot_ram_rom_size
> 0010b03d A _eiseg
> fffeb03d A _x
> fffeb03d D _binary_coreboot_ram_rom_end
> fffeb03d D _eliseg
> fffeb03d D _eram
> Works:
> 0000b222 A _binary_coreboot_ram_rom_size
> 0010b222 A _eiseg
> fffeb222 A _x
> fffeb222 D _binary_coreboot_ram_rom_end
> fffeb222 D _eliseg
> fffeb222 D _eram
> The broken one has a path of:
> /home/myles/try/buildrom-devel/work/coreboot/svn/
> The working one's path is:
> /home/myles/buildrom-devel/work/coreboot/svn/
> They were both working until yesterday.  I've tried everything I can
> think of.  I've removed the non-functional one's build directory
> completely.  The payloads are bit-for-bit identical.
> The only difference in the boot log before the reboot is this line:
> Works:
> Wrote coreboot table at: 00000500 - 00000788  checksum 5385
> Broken:
> Wrote coreboot table at: 00000500 - 0000076c  checksum 4fd2
> diffing the hexdump of the ROM files shows that the payload is identical.
> Any ideas?
> It is true that I have a working tree, but if I didn't I'd be hosed so
> I'd like to know the real cause.

That was the key.  I hadn't done a make clean in the working tree.
Rev 4000 broke it for me, but I'm still not sure why.  Once I was
doing make clean every time I could find the revision that was
breaking.  It looks like Rev 4000 changed the compile flags, so that's
where I'm going next.  Everything else in 4000 looks innocuous to me.


More information about the coreboot mailing list