[coreboot] Hosed ms-7032, I foolishly flashed the bios with a .700

Phil Neary philneary at yahoo.co.uk
Thu Jun 11 11:49:01 CEST 2009

Hi all, I'm not really sure how this works, I'm guessing its a bit similar to a forum, but in lieu of creating threads and posting posts, you email instead?

Okay the reason for this communication, is I messed up when flashing my bios and flashed it with A7032VMS.700 instead of a .rom or a .bin. I think MSI's flash utility changes the .700 into something usable before it actually flashes the bios to the chip, but their instructions were heavily Windows based and I totally forgot that .EXE's are also for Dos and not just Windows.

When it first happened, I tried the AMIBOOT.ROM recovery with the .700 and a few other bios' for my board that I downloaded from MSI, but they haven't worked. I thought it may be down to the fact that they're not .bin's or .rom's. So I recently fixed a friends PC and he has Sata drives so I was able to get the backup.bin from my hard drive and tried renaming it AMIBOOT.ROM and saving it to floppy, but Fedora named it amiboot.rom and I couldn't rename it. I'm not sure if this makes a difference, but it didn't work anyhow. Does Amiboot have to be capitalized?

I'm guessing it looks as though the recovery feature isn't going to work? Is there anything I haven't tried yet?

I can get a replacement chip for a fiver, but before I do I'd like to find out if that will defiantly work? Or could there be a small chance that a new chip even with the correct bios wouldn't work? I haven't done anything but try the recovery method, so nothing should be damaged.

Thank you for reading.

Kind regards


More information about the coreboot mailing list