[coreboot] vga not working

Arnaud Maye arnaud.maye at 4dsp.com
Mon Jul 27 09:47:24 CEST 2009

Hello Kevin,

So the vgabios came from the manufacturer in fact. I have removed the 
vgabios from the cbfs and
indeed seabios seems to execute the vgabios extracted from the card.

I have tried two GFX cards :
- Matrox G550 pci express 1 lane
- Club3D 8500GT Silent edition 16 lanes

Both of the cards behaving same besides colors of the squares. As an 
additional note, seabios does
boot my Linux from the HDD as there is a lot of activity on the hard 
disk led. It seems the faulty output
is displaying something as we can see the output moving in sync with 
what is supposed to be the linux

Attached is the boot log when the 8500GT card is attached. Being unsure 
about the maximum attachment
size in the mailing list I've been uploading video of the faulty output 
there :


The G550 output look same as the 8500GT output. The only difference is 
that most of the grey square are

Any idea what I could be doing wrong Kevin?

Thank you.


Kevin O'Connor wrote:
> On Sun, Jul 26, 2009 at 01:00:52PM +0200, Arnaud Maye wrote:
>> I've been on IRC for a GFX output issue on Friday. Actually the
>> output is always black or full of non sense square on the screen. I
>> have tried two graphic cards and in this respect it is fair to point
>> the issue outside of the vgarom.
> [...]
>> Scan for VGA option rom
>> Attempting to init PCI bdf 07:00.0 (dev/ven 42110de)
>> Searching CBFS for data file pci10de,0421.rom
>> Found CBFS file fallback/payload
>> Found CBFS file fallback/coreboot_ram
>> Found CBFS file pci10de,0421.rom
>> Copying data 58368 at 0xffe17a98 to 196608 at 0x000c0000
>> Checking rom 0x000c0000 (sig aa55 size 114)
>> Running option rom at c000:0003
> How did you obtain the vgabios?  Is this a vga adapter built-in to the
> motherboard, or one on an external card?
> For vga adapters on external cards, one should not add the vgabios to
> CBFS - SeaBIOS can extract the vgabios directly from the card.
> -Kevin

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: boot_geforce.TXT
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090727/a61c811b/attachment.ksh>

More information about the coreboot mailing list