[coreboot] m57sli, seabios and gpxe - kernel booting issues (BUG: INT 14 etc)

Ward Vandewege ward at gnu.org
Tue Jul 7 23:41:05 CEST 2009

Hi Kevin et al,

I'm trying to do a GPXE boot from seabios with coreboot on m57sli, and I'm
not getting very far. I'm using git/svn head for GPXE, seabios and coreboot.

I've tried various kernels - 2.6.22, 2.6.24, 2.6.27, 2.6.28 and 2.6.30 (all
ubuntu prebuilt kernels).

With 2.6.30, I get absolutely nothing, the kernel just hangs without output.
That's with the multi-segment patched mkelfImage or with the ordinary older

With 2.6.28-13-generic I get (manually copied, so there might be
transcription errors in this...):

  BUG: Int 14: CR2 ffffb0f0
     EDI 00000000  ESI 00000000 EBP c072bf3c ESP c072bf1c
     EBX 00000046  EDX 0000000e ECX 00000000 EAX ffffb0f0
     err 00000000  EIP c0119891  CS 00000060 flg 00010046
Stack: c011a26e 00000046 00000046 00000000 c072bf48 c0118a66 00f3390c
       c04fcb2f c05f62e0 c07dba60 00f3390c 00000000 c072bfb8 c073b44c
       00800000 00000000 00f3390c 00000000 c05f2c18 00100000 00000000

With 2.6.27-14-generic I get

  PANIC: early exception 0e rip 10:ffffffff8022d621 error 0 cr2

I found some references online that that panic might be caused by a kernel
bug, fixed in However, the same kernel boots fine if booted
directly from seabios (from disk). In fact, *all* the kernels I tried boot
fine from disk.

So is GPXE doing something funky here, or is there something else going on?


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior Systems Administrator

More information about the coreboot mailing list