[coreboot] [OpenBIOS] OpenBIOS SVN r416 breaks coreboot-v3

Myles Watson mylesgw at gmail.com
Wed Jan 28 20:28:21 CET 2009

> > What version of qemu are you using?  I tried building my own image,
> > and I don't see the failure.  I'm using Coreboot v3 1123 like you are,
> > OpenBIOS 428, and qemu 0.9.1-5ubuntu3.  I'm attaching my log.  I guess
> > it could be a difference in the configuration of OpenBIOS too.
> I think I mentioned in my original email that I was using SVN pulls of
> all 3 of openbios, coreboot and qemu. In fact a quick check here shows:

Sorry I forgot that.

> coreboot-v3:	r1123
> openbios:	r428
> qemu:		r6466
> It looks as if you may have found part of the problem with regard to the
> qemu version; I've just compiled up qemu 0.9.1 from source and tried it
> with the same bios.bin generated from coreboot-v3/openbios above - and
> it boots! So perhaps qemu is involved in this somehow? Can you verify at
> your end?

Yes.  qemu 0.9.1 works with v2+OpenBIOS and v3+OpenBIOS, but the latest qemu
doesn't.  The latest qemu works with v2 or v3 +OpenBIOS r186, so it looks
like an interaction between OpenBIOS and qemu.


More information about the coreboot mailing list