[coreboot] [PATCH] flashrom patch easier board_pciid_enables parsing

ron minnich rminnich at gmail.com
Wed Jan 14 00:23:26 CET 2009

On Tue, Jan 13, 2009 at 3:34 PM, Luc Verhaegen <libv at skynet.be> wrote:
> On Tue, Jan 13, 2009 at 10:02:15PM +0100, Stephan GUILLOUX wrote:
>>    Hello,
>> Similarly to flashchips array, this patch intends to make the table
>> board_pciid_enables more readable.
>> Also in attachment.
> For certain versions of readable. What real problem does this solve?

1. Next time someone adds a new struct member, we avoid mistakes of
ordering of initializers
2. we avoid mistakes in the first place.

The .x = y stuff was added for a (good) reason, I think this is an improvement.

Acked-by: Ronald G. Minnich <rminnich at gmail.com>

More information about the coreboot mailing list